Sunday, September 18, 2011

XAMPP on 64 Unix Operating Systems

hello all,

If you have a 64-bit unix like operating system you cant run the Xampp because Xampp currently doesn’t have a 64-bit compiled version. Now what will you do in this condition ?
When you are trying to start a lampp from terminal you might be getting this kind of error:: XAMPP is currently only availably as 32 bit application. Please use a 32 bit compatibility library for your system. Dont worry this is just a simple validation code in /opt/lampp in lampp file on line number 86. Now we will run the xampp under 64-bit operating system even though it is not supporting the 64-bit compiled version.
Please follow the steps in order to start your xampp with 64-bit operating system.

1) Comment the lines in /opt/lampp lampp file from 78 to 90.

     which will now look like this

# XAMPP is currently 32 bit only
#case `uname -m` in
#    *_64)
#    if /opt/lampp/bin/php -v > /dev/null 2>&1
#    then
#        :
#    else
#        $de && echo "XAMPP gibt es zur Zeit nur als 32-Bit Applikation. Bitte verwende eine 32-Bit Kompatibilitaetsbibliothek fuer Dein System."
#        $de || echo "XAMPP is currently only availably as 32 bit application. Please use a 32 bit compatibility library for your system."
#        exit
#    fi
#    ;;

2) Open your terminal (if it is ubuntu 10.10 go to Appllication>>Accessories>>Terminal enter this command sudo apt-get install ia32-libs if it is asking for root password then enter the password, wait till it downloads all of the 32-bit libs.

Once it is done just enter the following command at the terminal /opt/lampp/lampp start

Thats It!!! now you are free to use the xampp under 64-bit operating system.

Enjoy & be open.
long live linux


  1. Did you meant comment on the first step?

  2. Thanks! It worked! I just had a problem with MySQL, it just doesn't started.

  3. It didn't work even when I downloaded the libraries:

    sudo apt-get install ia32-libs

  4. I am using kubuntu and eventhough ia32-libs are installed it didnt work.

  5. you don't need to comment any lines. remove previous installation by rm -rf /opt/lampp and install ia32-libs. now re-install xampp it should work like a charm.

  6. I Am not able to download ia32-libs its says.
    $ sudo yum install ia32-libs
    Loaded plugins: security [Errno 14] HTTP Error 404: Not Found
    Trying other mirror.
    Error: Cannot retrieve repository metadata (repomd.xml) for repository: torproject. Please verify its path and try again

    Please help me on this

  7. easiest way to install xampp on 64 bit linux is to install wine first then install xampp ,read complete tutorial with screen shot

    1. Dude installing wine is not an option! Its never been the option! on my blog no one uses the Windows word! If you are so much a windows fan then use windows!!

  8. This comment has been removed by the author.

  9. can any one give me direct download link for Wine or ia32-libs. yum is not working on my machine.

  10. I followed the steps 1 and 2, but then it gave the following error:
    No package ia32-libs available.
    Error: Nothing to do
    I am a complete newbie to linux.....Please help me!
    I am using fedora 18.